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Software License and Limited Warranty

Please read this section carefully before installing Infinite Pictures™ software.
This agreement licenses the software to you. It also contains warranty and
liability disclaimers. By selecting the “I AGREE” button during installation,
you are accepting the software and agreeing to become bound by the terms of
this agreement. If you do not wish to do so, select the “I DON'T AGREE”
button and delete all files in your possession relating to this product.

1. Definitions

(a.) “Infinite Pictures software” means the software programs included in
this product, and all related updates supplied by Infinite Pictures.

(b.) “Infinite Pictures product” means the Infinite Pictures software and the
supporting documentation, files and multimedia content (such as panorama
files), and all related updates supplied by Infinite Pictures.

2. License. This agreement allows you to:

(a.) Use the Infinite Pictures software on a single computer.

(b.) Make one copy of Infinite Pictures software in machine-readable form
solely for backup purposes. On any such copy you must reproduce all copyright
notices and any other proprietary legends found in the original copy of the
Infinite Pictures software.

(c.) Certain Infinite Pictures software is licensed with additional rights as
set forth in the Supplemental Rights Addendum that may be included elsewhere
in this Infinite Pictures product.

3. Supplementary Licenses

Certain rights are not granted under this agreement, but may be available under
a separate agreement. If you would like to enter into a Site or Network License,
or if you would like to sell files generated by the Infinite Pictures product,
please contact sales@smoothmove.com or call the Infinite Pictures sales
department at 1-800-990-2449.

4. Restrictions

You may not make or distribute copies of the Infinite Pictures product, or
electronically transfer the Infinite Pictures software from one computer to
another or over a network. You may not decompile, reverse engineer,
disassemble, or otherwise reduce the Infinite Pictures software to a human-
perceived form. You may not modify, rent, resell for profit, distribute or create
derivative works based upon the Infinite Pictures software or any part thereof.
You will not export or reexport, directly or indirectly, the Infinite Pictures
product into any country prohibited by the United States Export Administration
Act and the regulations thereunder.

mailto:sales@smoothmove.com
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5. Ownership

The foregoing license gives you limited rights to use the Infinite Pictures
software. Although you own the disk on which the Infinite Pictures software is
recorded, you do not become the owner of, and Infinite Pictures retains title to,
the Infinite Pictures product, and all copies thereof. All rights not specifically
granted in this agreement, including Federal and International Copyrights, are
reserved by Infinite Pictures.

6. Limited Warranties

(a.) Infinite Pictures warrants that, for a period of ninety (90) days from
the date of delivery (as evidenced by a copy of your receipt): (i) when used with
a recommended hardware configuration, the Infinite Pictures software will
perform in substantial conformance with the documentation supplied as part of
the Infinite Pictures product; and (ii) that the media on which the Infinite
Pictures software is furnished will be free from defects in materials and
workmanship under normal use. EXCEPT AS SET FORTH IN THE
FOREGOING LIMITED WARRANTY, INFINITE PICTURES DISCLAIMS
ALL OTHER WARRANTIES, EITHER EXPRESS OR IMPLIED,
INCLUDING THE WARRANTIES OF MERCHANTABILITY, FITNESS
FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IF
APPLICABLE LAW IMPLIES ANY WARRANTIES WITH RESPECT TO
THE INFINITE PICTURES PRODUCT, ALL SUCH WARRANTIES ARE
LIMITED IN DURATION TO NINETY (90) DAYS FROM THE DATE OF
DELIVERY. No oral or written information or advice given by Infinite
Pictures, its dealers, distributors, agents or employees shall create a warranty or
in any way increase the scope of this warranty.

(b.) SOME STATES DO NOT ALLOW THE EXCLUSION OF IMPLIED
WARRANTIES, SO THE ABOVE EXCLUSION MAY NOT APPLY TO
YOU. THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS AND
YOU MAY ALSO HAVE OTHER LEGAL RIGHTS WHICH VARY FROM
STATE TO STATE.

7. Exclusive Remedy

Your exclusive remedy under Section 6 is to return the Infinite Pictures
software to the place you acquired it, with a copy of your receipt and a
description of the problem. Infinite Pictures will use reasonable commercial
efforts to supply you with a replacement copy of the Infinite Pictures software
that substantially conforms to the documentation, provide a replacement for the
defective media, or refund to you your purchase price for the Infinite Pictures
software, at its option. Infinite Pictures shall have no responsibility with respect
to Infinite Pictures software that has been altered in any way, if the media has
been damaged by accident, abuse or misapplication, or if the nonconformance
arises out of use of the Infinite Pictures software in conjunction with software
not supplied by Infinite Pictures.
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8. Limitations of Damages

(a.) INFINITE PICTURES SHALL NOT BE LIABLE FOR ANY
INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES
(INCLUDING DAMAGES FOR LOSS OF BUSINESS, LOSS OF PROFITS,
OR THE LIKE), WHETHER BASED ON BREACH OF CONTRACT, TORT,
(INCLUDING NEGLIGENCE), PRODUCT LIABILITY OR OTHERWISE,
EVEN IF INFINITE PICTURES OR ITS REPRESENTATIVES HAVE BEEN
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES AND EVEN IF A
REMEDY SET FORTH HEREIN IS FOUND TO HAVE FAILED OF ITS
ESSENTIAL PURPOSE.

(b.) Infinite Pictures' total liability to you for actual damages for any cause
whatsoever will be limited to the greater of $500 or the amount paid by you  for
the Infinite Pictures software that caused such damages.

(c.) SOME STATES DO NOT ALLOW THE LIMITATION OR
EXCLUSION OF LIABILITY FOR INCIDENTAL OR CONSEQUENTIAL
DAMAGES, SO THE ABOVE LIMITATION OR EXCLUSION MAY NOT
APPLY TO YOU.

9. Basis of Bargain

The limited warranty, exclusive remedies and limited liability set forth above
are fundamental elements of the basis of the bargain between Infinite Pictures
and you. Infinite Pictures would not be able to provide the Infinite Pictures
software on an economic basis without such limitations.

10. General

This agreement shall be governed by the internal laws of the State of Oregon.
This agreement contains the complete agreement between the parties with
respect to the subject matter hereof, and supersedes all prior or
contemporaneous agreements or understandings, whether oral or written. All
questions concerning this agreement shall be directed to: Infinite Pictures, Inc.,
33 Northwest First Avenue, Suite 1, Portland, Oregon 97209, attention: Chief
Financial Officer.

This is an agreement between you, the end user, and Infinite Pictures, Inc.
By using this software, you are agreeing to become bound by the terms of this
agreement.

IF YOU DO NOT AGREE TO THE TERMS OF THIS AGREEMENT, DO
NOT USE THIS SOFTWARE.  PROMPTLY DESTROY IT COMPLETELY.
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Notices and Trademarks

Publication Notice
We have done our best to ensure that the material found in this manual is both
useful and accurate.  However, please be aware that errors may exist in this
manual, and neither the authors nor Infinite Pictures, Inc., make any
guarantees concerning the accuracy or possible uses of the information found
here.

Copyright Notice
Copyright  1995-1997 by Infinite Pictures, Inc.  All rights reserved.  No
portion of the contents of this publication may be reproduced or transmitted in
any form or by any means without the express written permission of Infinite
Pictures, Inc.

Technical Support
Infinite Pictures offers on-line support for 90 days from the date that you
register your Real World Navigation™ product.  During this 90-day period, our
Technical Support staff will respond to your E-mail requests at no additional
charge.  To register for technical support during this 90-day period, simply E-
mail, fax, or send in your registration card, which is included with your
software documentation.

To receive technical support, send E-mail to support@smoothmove.com.  Be
sure to include the following information:

• Your name

• Product name and version

• Product registration number

• Description of your computer and operating system

• Description of your problem or question

mailto:support@smoothmove.com
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After the initial 90-day period, we encourage you to upgrade to an Annual
Technical Support and Maintenance Agreement (ATSMA).  The annual
agreement includes the following:

• One year of E-mail technical support immediately following your
initial 90-day period

• Free updates of purchased products as they ship

• Special discounts on product upgrades

• Special prices on other promotions during the year

To purchase an ATSMA, please call Infinite Pictures at
1-800-990-2449 or send E-mail to support@smoothmove.com.

For more information about technical support from Infinite Pictures, visit our
Web site at http://www.smoothmove.com.  There, you’ll find a list of FAQs that
address some of the most common technical questions about Real World
Navigation products, along with other hints to help you along.

Trademark Acknowledgments
Real World Navigation, Infinite Pictures, and SmoothMove are trademarks of
Infinite Pictures, Inc.  LightWave is trademark of NewTek, Inc.  Director is a
trademark of Macromedia.  Pentium is a registered trademark of Intel
Corporation.  Microsoft and Windows are registered trademarks of Microsoft
Corporation.  All other brand or product names are trademarks or registered
trademarks of their respective owners.

mailto:support@smoothmove.com
http://www.smoothmove.com
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Overview

Welcome to the Real World Navigation™ Suite for LightWave 3D.  With
the Real World Navigation Suite, you can create and view 360-degree
spherical panoramas with a click of the camera.  The Real World
Navigation Suite fits comfortably into the LightWave 3D environment.

The Real World Navigation Suite for LightWave 3D is easy to install and
easy to use.  The Real World Navigation Suite installation program takes
care of nearly all the details.

Creating a SmoothMove Panorama
It’s easy to create and save SmoothMove™ panoramas — 360-degree
interactive views — from your existing 3D models in LightWave 3D.  All
you need to do is load your 3D model, place the panoramic camera, and
click the button to render the complete panorama.  This manual provides a
tutorial that shows how to do this.

You can also use two other tools from the Real World Navigation Tools
and Design Series products to create SmoothMove panoramas:

• The CG Seamer lets you build panoramas from the output of
just about any computer graphics (CG)  rendering software.
The CG Seamer is available as part of the Real World
Navigation Tools and Design Series standalone products.
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• With the Photo Seamer, you can create a panorama by
seaming together a set of three fisheye photographic images.
The Photo Seamer is available as part of the Real World
Navigation Design Series standalone product.

Bringing the Panorama to Life
The Real World Navigation Suite gives you a new level of interactivity,
visual richness, and depth of content.  You can use hotspot linking to make
your panorama images come alive.  With the Hotspot Editor, you can
“annotate” a panorama by associating regions of the panorama image with
user-initiated audio and video clips, application launching, World Wide
Web sites, or other actions.  What’s more, you can use the Avatar Editor to
create avatars — interactive animations, created from multiple views of an
object — that users can activate in your panorama by clicking the mouse
within the associated hotspot region.

Viewing and Interacting with a Panorama
Once you’ve created and saved your panorama, you can compress the
panorama and then distribute it to your users:

• You may distribute the standalone SmoothMove Viewer for
both PC and Macintosh at no additional cost.  Make your
architectural models come alive for your customers!

• Build an impressive multimedia presentation using industry
standard Macromedia Director™.  You can add panoramas to
presentations, thereby providing the full coupling of
interactive space, with text, video, sound and other images.

• Add interest to your Web site by embedding a spherical
panorama in your home page. Building a SmoothMove-
enabled Web site is as easy as inserting a graphic:  all it takes
is a single line of HTML code.

SmoothMove panoramas set your Web site apart from more
static sites.  Users will appreciate the fluid real-time panning
and zooming motion and the high-quality graphic images.
What’s more, the 360-degree freedom of motion gives you
more virtual real estate on the screen.
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To view the SmoothMove panoramas on your Web page,
users can obtain a free Internet Browser Plug-in from the
Infinite Pictures™ Web site (http://www.smoothmove.com).

In the tutorial portion of this guide, you’ll learn how to use the Real World
Navigation plug-in to render content-rich, immersive panoramas — in less
than an hour.

How the Real World Navigation Suite Works
The Real World Navigation Suite for LightWave 3D consists of an
animation saver and two object motion handlers for use in LightWave 3D.

• The animation saver collects rendered frames and compiles
them into a completed panorama.

• The object motion handlers are used to control camera and
object motions during the rendering process.

The Real World Navigation Suite renders six frames of an animation
sequence, collecting the images and then compiling the set of frames into a
complete panoramic image.  The six images correspond to the faces of a
cube, as shown below:

 Back
Right

 Top

 Front

 Top

 Back

 Bottom

 Right Left

Source images

To obtain the six images, the Real World Navigation animation saver
renders the panorama as part of an animation, pointing the camera in the
appropriate direction for each face.  To ensure that the camera is
appropriately aimed and positioned for rendering, you apply the camera
controller item motion handler to the camera.  Similarly, to ensure that all

http://www.smoothmove.com
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objects in the scene remain stationary during the rendering process, you
apply the object controller item motion handler to keyframed objects.

The animation saver ensures that the images from the frame sequence are
collected and seamed into a complete panoramic image.  The animation
saver also controls compression options and optionally displays the
completed panorama at the end of the rendering process.

Visit Our Web Site!
You can find lots of helpful information by visiting our Web site at
http://www.smoothmove.com.  Here are some of the things you’ll find
there:

• A Gallery of panoramas produced by artists from around the
world and by other users of Real World Navigation products.
In the Gallery, you’ll find software and HTML samples that
you can download.  You can also enter contests and sign up to
be a beta tester of Real World Navigation products.

• Links to the Web sites of some of our customers, our
technology partners, and other exciting sites.

• Information about other Real World Navigation products
available from Infinite Pictures.  You can order and register
without leaving our Web site.

• Downloads of demonstration versions of many Real World
Navigation products, including free viewers and other
software.

• What’s New? — A page with our newest links, information
about our partners, samples, and news about Infinite Pictures.

• A Company Backgrounder that introduces you to Infinite
Pictures, Inc.

http://www.smoothmove.com
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Installation

System Requirements
To use the Real World Navigation Suite for LightWave 3D, your computer
must meet these requirements:

• LightWave version 4.0 or newer

• Pentium 90 MHz or faster

• Windows NT 4.0 or Windows 95

• At least 32 MB of RAM

• Graphics card (16-bit display or better preferred)

• A hard disk with at least 20 MB of free space

Installing the Real World Navigation Suite
To install the Real World Navigation Suite for LightWave 3D, perform the
following steps:

1. If any Windows applications are running on your computer,
close them now.

2. If you are installing from CD ROM, insert the Real World
Navigation CD ROM disc into your CD ROM drive.

3. Choose the Run command from the Start Menu.
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4. If you are installing from CD ROM, type
D:\RWN_SUITE_LIGHTWAVE.EXE (where D: is the letter that
designates your CD ROM drive) and click OK.

 If you are installing software that you downloaded from our
Web site, click Browse and navigate to the directory where
you downloaded the software.   Type the filename
RWN_SUITE_LIGHTWAVE.EXE and click Open.  Then click OK.

5. The Real World Navigation Installer dialog box appears.
Review the instructions, then read and accept the license
agreement.

6. While the Installer is installing Real World Navigation on
your computer, follow the instructions on your screen.

7. When the Installer asks you where to install the software
components, verify that each directory location is correct. We
strongly recommend that you accept the default directory
locations for the Infinite Pictures standalone programs and
the Internet browser plug-ins.

8. When installation is complete, the Installer will display a
message to indicate that your installation was successful.

If you should encounter any problems during installation, please send E-
mail to support@smoothmove.com.  Be sure to include your registration
information.

mailto:support@smoothmove.com
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Tutorial

In this tutorial, you’ll do the following:

• Load an existing scene that contains a simple model

• Configure your camera

• Configure the Motion Graph

• Configure the Animation Path

• Render and view the panorama

In this tutorial, we assume that you are familiar with Microsoft Windows
95 or Windows NT, and that you are somewhat familiar with LightWave
3D and its conventions.

Load a Scene
1. If you haven’t already done so, start LightWave 3D.

2. From the File menu, select Load Scene.

3. In the Load Scene File dialog box, navigate to the directory
where you installed the Real World Navigation Suite for
LightWave 3D (typically,  C:\PROGRAM FILES\INFINITE
PICTURES\REAL WORLD NAVIGATION\SUITE FOR LIGHTWAVE
3D).

4. In that directory’s TUTORIAL subdirectory, select the file
TUTORIAL.LWS.
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Configure the Camera for Panorama Reading
To render a SmoothMove panorama, it is important that the camera have a
90-degree horizontal and vertical field of view.  To obtain the proper field
of view, perform these steps:

1. At the top of your LightWave window, click Camera to open
the Camera panel.

2. In the Camera panel, perform the following actions:

a. Click the Custom Size check button.

b. Enter any square image size.  To do this, make sure that
the Width and Height are set to the same value (for
example, 512).

c. Set the Pixel Aspect Ratio to Square Pixels.

d. Set the Zoom Factor to 1.0.

e. Press the Tab key.  Confirm that the Equivalent Lens is
set to 8mm and that the Field of View is 90°.

Hint:  To speed up rendering, turn Antialiasing off.
Also, make sure that Soft Filter is not selected.
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3. Verify that your Camera panel looks like this:

 

4. Click Continue.
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5. In the Edit menu (in the left margin of the LightWave 3D
window), select the menu item Camera.

6. Click in the middle of the scene, then use the mouse to
position the camera.  The direction of the camera will define
the directions of the front and top of the panorama.

 (This image courtesy of NewTek, Inc.)

Apply the Camera Motion Control
The final step in setting up the camera for rendering is to select the camera
controller.  To select the camera controller:

1. In your scene, make sure that the selected item (near the
bottom of the window) is Camera.
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2. Click the Motion Graph button to open the Motion Graph
panel.

3. In the Motion Graph panel, click the Motion Plug-ins button.

 A panel containing a pop-up menu of Plug-Ins will open.

4. In the Motion Plug-ins panel, pull down the Plug-in 1 menu
and select RWNCameraController.

5. Click Continue to close the panel.

6. Click Use Motion to close the Motion Graph panel.



12  ••  Tutorial Real World Navigation for LightWave 3D

Configure the Animation Path
Now that you have properly arranged your scene and camera, it’s easy to
render a SmoothMove panorama.  First, though, you must select the
panorama saving options.  To do so, perform the following steps:

1. At the top of your LightWave window, click Record to open
the Record panel.

2. In the Record panel, change the Animation Type to
RWNSaver.

3. Click Save Animation.

4. In the Save Animation dialog box, navigate to your TUTORIAL
directory (typically,  C:\PROGRAM FILES\INFINITE
PICTURES\REAL WORLD NAVIGATION\SUITE FOR LIGHTWAVE
3D\TUTORIAL).

5. In the TUTORIAL directory, save the panorama in the file
TESTPAN.PAN.  Type the filename, then click Open.

You must enter the .PAN extension.  LightWave 3D doesn’t do
this for you.
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6. Click Continue to close the Record panel.

Render and View the Panorama
Now, begin rendering the images and select the panorama parameters.

1. At the lower left of your LightWave 3D window, click
Render to open the Render Scene panel.

2. In the Render Scene panel, set First Frame to 1 and Last
Frame to 6.  This selects the sequence of six frames to
render.  (Remember that it takes six frames to render a
SmoothMove panorama.)

3. Set the Frame Step value to 1.

4. Set the Frame Advance method to Automatic.

 

5. Verify that all information is correct, then click OK to start
rendering.
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6. In the Real World Navigation Plug-in dialog box, enter the
size for your panorama image.

 The displayed size of the panorama will be a default size
based on your camera settings.

7. If you’re interested in examining your current compression
options, you can click Compression, but don’t change any
values during this tutorial.

8. Verify that the Suppress View Window checkbox is not
selected.  When this box is not selected,  the panorama will
automatically be displayed when it is complete.

9. Click OK to begin rendering.

 You’ll need to wait patiently while LightWave renders each
of the panorama’s six frames.  This will take anywhere from
2 to 5 minutes, depending on your processor speed,  the
amount of available memory, and the complexity of the six
individual frames.

 When all six images are complete, Real World Navigation
seams the images and saves the panorama.
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10. When the SmoothMove Viewer window appears, you can
examine your panorama.

• To pan, hold down the left mouse button near the center
of the window and move the mouse in the direction that
you want to pan.

• To zoom, hold down the Ctrl key and left mouse button
simultaneously, and move the mouse up (to zoom in) or
down (to zoom out).

11. When you’re done, close the SmoothMove Viewer window,
then close LightWave.

What Next?
Now that you’ve created your panorama, you can use other Real World
Navigation tools to add spice:

• You can use the HotSpot Editor to associate audio or video
clips, Web links, or other actions with regions of the
panorama image.  For details, see “Hotspots” on page 19 of
this guide.
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• You can use the Avatar Editor to build Real World
Navigation avatars that you can include in your panorama.
For details, see “Creating Avatars” on page 23.

• You can incorporate your panorama into World Wide Web
pages.  For details, see “Including Panoramas in Web Pages”
on page 25.
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Using the SmoothMove
Viewer

You use the SmoothMove Viewer to view and interact with SmoothMove
panoramas.

Opening a Panorama
1. To start the SmoothMove Viewer, go to the Start menu and select

Programs > Real World Navigation > SmoothMove Viewer.

2. In the SmoothMove Viewer window, select File > Open.

3. In the dialog box, navigate to the directory that contains the
panorama (.PAN) file that you want to view.

4. Select the panorama and click OK.

5. When the SmoothMove Viewer window appears, you can examine
your panorama.

• To pan, hold down the left mouse button near the center of
the window and move the mouse in the direction that you
want to pan.

• To zoom, hold down the Ctrl key and the left mouse button
simultaneously, and move the mouse up (to zoom in) or down
(to zoom out).

• To return the SmoothMove Viewer to its initial view, press
the space bar.
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Activating Hotspots
When the pointer is inside a defined hotspot, the cursor changes to an arrow.
To activate the hotspot, click the left mouse button.

Controlling Real World Navigation Avatars
Some hotspots may activate Real World Navigation avatars.

• To animate a Real World Navigation avatar, click and hold down
the left mouse button on the avatar and move the mouse.

• To move an avatar, hold down the Ctrl key and the left mouse
button and move the mouse.

• To deactivate an avatar, click the right mouse button in the
panorama.
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Hotspots

A hotspot associates a region of a panorama image with an action.  You
can use hotspots to define user-initiated audio or video clips, application
launching, World Wide Web sites, or other actions.

Adding Hotspots to Your SmoothMove
Panorama
After you have created a SmoothMove panorama, you can add hotspots.
To add a hotspot, perform these steps:

1. Start the Hotspot Editor.  To do so, go to the Start menu and
select Programs > Real World Navigation > Hotspot
Editor.

2. In the Hotspot Editor window, select File > Open.

3. In the dialog box, navigate to the directory that contains the
panorama (.PAN) file where you’ll be adding hotspots.

4. Select the panorama and click Open.

Any previously defined and saved hotspots appear in red.

Navigating a Panorama in the Hotspot Editor
When the Hotspot Editor window appears, you can navigate the panorama.
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• To pan, hold down the left mouse button near the center of
the window and move the mouse in the direction that you
want to pan.

• To zoom, hold down the Ctrl key and the left mouse button
simultaneously, and move the mouse up (to zoom in) or down
(to zoom out).

Setting the Panorama’s Initial View
To establish the initial view for this panorama in the SmoothMove Viewer,
select File > Set Initial View while you’re in the Hotspot Editor window.

Once you’ve done this, the current view of this panorama will be displayed
whenever it is loaded into the SmoothMove Viewer, or when you press the
space bar in the SmoothMove Viewer.

Creating a Hotspot
To create a hotspot in your SmoothMove panorama, perform these steps:

1. Place the cursor at one corner of the desired hotspot region.

2. Press down the right mouse button, drag the cursor to the
opposite corner of the desired region, then release the right
mouse button.

3. In the Define Hotspot dialog box, provide a description for
the new hotspot.  Then click OK.

 Here’s a summary of what you can enter in the Hotspot
description box.  All values except the filenames are optional.
You must use lowercase letters for optional values (normal,
not NORMAL). Default values are shown in boldface type.

Type of file Hotspot description
syntax

Explanation

 .AVI
(video clip)

(full window) FILE.AVI The video file will play in the entire
application window.

(local window) FILE.AVI The video file will play only inside
the hotspot rectangle.

 .AVT
(avatar)

(x,y) FILE.AVT
For example:
(1,0.5) HELICOPTER.AVT

The avatar will “animate” (spin) at x
images/sec in its first dimension and
y images/sec in its second
dimension.  Defaults: (0,0).
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 .EXE
(application)

(normal) FILE.EXE datafile
(minimized) FILE.EXE
(maximized)FILE.EXE

Starts the application

 .PAN
(panorama)

(preserve view) FILE.PAN The panorama will be displayed with
the same view orientation as the
current panorama.  By default, the
panorama comes up facing “north.”

 .WAV
(video clip)

(repeat) FILE.WAV By default, the audio file will play
once and then stop.

URLs Any URL hotspots that point to files
on the user’s local drive must have
the format “file://pathname”.

• Any file extension not listed here will be launched using the
registered viewer.  For example, .DOC files will be opened with
Microsoft Word or Wordpad.

• The SmoothMove Viewer does not recognize URLs.

• The SmoothMove Plug-in for Internet Browsers does not
recognize .EXE files.

Selecting a Hotspot
To select an existing hotspot, place the cursor anywhere within a hotspot
rectangle, and click the right mouse button. The selected hotspot appears
outlined in green.

Deleting a Hotspot
To delete a hotspot, perform these steps:

1. Click the right mouse button inside the hotspot.

2. From the right mouse button menu, select Delete Hotspot.

 You can also press the Delete key or select the menu item
Edit>Delete Hotspot.
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Editing a Hotspot
To edit an existing hotspot,  perform these steps:

1. Click the right mouse button inside the hotspot.

2. From the right mouse button menu, select Edit Hotspot.

 You can also press the Delete key or select the menu item
Edit>Edit Hotspot Description.

3. In the Edit Hotspot dialog box, make any changes to the
action associated with this hotspot.

Testing a Hotspot
To test a single existing hotspot,  perform these steps:

1. Click the right mouse button inside the hotspot.

2. From the right mouse button menu, select Test Hotspot.

 You can also press the Delete key or select the menu item
Edit>Test Hotspot.

To test all existing hotspots, select the menu item File>Tour All Hotspots.

Saving Your Hotspots
After you’ve defined all of your hotspots, save the panorama file.  To do so,
perform these steps:

1. Select the menu item File>Save.

2. In the dialog box, navigate to the directory where you want to
save your panorama.

3. Verify that the panorama file name (.PAN) and all other
information is correct.  Then click Save.
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Creating Avatars

In this brief tutorial, you’ll use the Avatar Editor to transform a sequence
of images into an animated avatar object that users can place in their
panoramas.

Create Your Avatar
1. From the Start menu, select Programs > Real World

Navigation > Avatar Editor.

2. In the Avatar Editor window, select File > Open.

3. In the dialog box, navigate to the directory C:\PROGRAM
FILES\INFINITE PICTURES\REAL WORLD
NAVIGATION\SAMPLES\AVATAR EDITOR.

4. In that directory, select all eight AASPINXX.BMP files and
click Open.

5. In the Avatar Grid dialog box, accept all default values and
click OK.

6. Look in your Avatar Editor window:  it’s a dancing aardvark!

 To watch the aardvark play hacky-sack, click the up-arrow
and down-arrow buttons.  (Aardvark image courtesy of Bill
Tillman.)

7. Now, save the aardvark avatar.  Select File>Save As, then
navigate to the SAMPLES\AVATAR EDITOR directory (see step 3).
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8. In that directory, save the panorama in the file
AARDVARK.AVT.  Type the filename, then click Open.

Place the Avatar in Your Panorama
Now, you’ll use the Hotspot Editor to place the new avatar in your
panorama.

1. From the Start menu, open the Hotspot Editor.

2. In the Hotspot Editor window, select File > Open.

3. In the dialog box, navigate to the SAMPLES\AVATAR EDITOR
directory  (see step 3 in the previous section).

4. Select the panorama file SAMPLEPAN.PAN, then click Open.

5. Use the left mouse button to define the hotspot region that you
want to associate with your avatar.

6. When the Define Hotspot dialog box appears, navigate to the
SAMPLES\AVATAR EDITOR directory and provide
AARDVARK.AVT as the Hotspot description.  Then click OK.

7. To activate the avatar, move the mouse cursor inside the
hotspot.  Then click the right mouse button and select Test
Hotspot.
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Including Panoramas in
Web Pages

To insert a GIF or JPG graphic into a Web page, you use a line of HTML
that looks like this:

<img src="./graphics/FILENAME.gif">

Inserting a SmoothMove Panorama into a Web page is almost as easy.  All
you need to do is include the HTML embed command with its command-
line arguments:

<embed src="./graphics/FILENAME.pan" width=WWW height=HHH
type="application/x-pan">

The embed command uses the following arguments:

src This is the filename for the SmoothMove panorama that
you’re including in the Web page.

width,
height

These values set the dimensions of the panorama
window.

type This value should be set to "application/x-pan".
This MIME type allows your Web server to display
SmoothMove panoramas (.PAN files) correctly, even if
the Web server is not configured to your specifications or
is outside your control.

pan, tilt,
roll

These values specify the initial amount of panning,
tilting, and rolling of the viewer.
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The following HTML example will display the panorama PDXBREW.PAN,
with the camera slowly panning.

<embed src="./graphics/pdxbrew.pan" width=450
height=250 type="application/x-pan" pan=20>

Tutorial Files
You can find sample HTML files in the following directory: C:\PROGRAM
FILES\INFINITE PICTURES\REAL WORLD NAVIGATION\SAMPLES\HTML
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Advanced Topics

Rendering Multiple SmoothMove Panoramas
This section is primarily for more advanced users of LightWave 3D and
the Real World Navigation Suite.

Rendering multiple panoramas can be done in several ways.  In some
cases, there are some very important considerations to make regarding the
time based changes in a scene.

The simplest way to render multiple panoramas from a single scene is to
set up a scene with no time dependent changes and simply move the
camera for each desired panorama.

Setting up a Scene for Panorama Rendering
When arranging a scene for panorama rendering, it is necessary to follow a
few guidelines.  Because panoramas must be rendered as animation
sequences, some time-based effects cannot be used.  Lens flares can also be
a problem under certain circumstances.  This section of the guide lists
some exceptions to these rules and methods for handling keyframed
motion.

Avoid any time-based changes to the scene other than those which are
explained here.  Do not use blurs, object or texture metamorphosing,
lighting changes, fades, etc.  A panorama can be rendered when such
effects are in use, but the seams where the source images meet will likely
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be visible.  For more about this, refer to “How the Real World Navigation
Suite Works”, on page 3 of this guide.

Lens flares in LightWave 3D are created as a post-processing effect for
each image.  Flares are applied only to lights that are visible in a given
frame.  This can also result in visible image seams in the final panorama.
Avoid lens flares that extend beyond the edge of any frame.

Using Time-Dependent Changes in a Scene
It is possible to create multiple panoramas at once by setting up a
keyframed motion for the camera and rendering a long sequence of frames.
It is also possible to use envelopes in the scene.  This can be very useful for
overnight rendering of a group of panoramas.

Time-dependent changes such as these should be carefully planned.  They
should also be arranged with a great deal of care in order to obtain
seamless panoramic images.  The order of application is important.  We
recommend that the scene be saved often.

To prepare the scene for time-dependent changes:

1. Open the Scene panel.

2. Set the first frame of the scene to zero.

3. Click the Continue button to close the Scene panel.

Keyframed motion should be set up before applying the motion handler
portions of the plug-in to the camera or any scene objects.  To set up
keyframed motions in the scene:

1. Define keyframes and motions as normal.

 It is a good idea to save the scene after this step.  That could
make it easier to go back and edit the motions.

2. Open the Scene panel.

3. Click the Scale All Keys button.

 The Scale All Keys panel will open.

4. Enter the value 6.0 in the value field labeled Scale Frames
by.

5. Click the OK button to close the Scale All Keys panel.

6. Click the Continue button to close the Scene panel.
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7. Apply the camera motion controller portion of the plug-in to
the camera.

 Follow the instructions given in the section “Apply the
Camera Motion Control” on page 10 of this guide.

8. Apply the object motion controller portion of the plug-in to
any objects with keyframed motion in the scene.

 Follow the instructions given in the section “Applying the
Camera Motion Control,” but replace
RWNCameraController with RWNObjectController.

After you’ve performed these steps, the scene will look the same as it did
after step 1, but the motions will be at different frame locations.  When
stepping through the frames, object locations should change only at six-
frame intervals.

Envelopes in the scene should be set up after configuring for keyframed
motion.  Although envelope use is beyond the scope of this manual, here
are some general guidelines to follow:

• Do not use a zoom factor envelope for the camera.

• Turn off spline controls for the envelopes.  This will help
ensure that envelope values remain constant during any six
frame sub-sequence.

• Make sure changes occur only at the boundary of each six-
frame sub-sequence.  For example, the envelope values should
be constant for frames 0–5.  The values could then change
between frames 5 and 6.  The values should then remain
constant again between frames 6 and 11.

If the desired time-based changes are arranged appropriately, all of the
panoramas should be seamless.

Setting the Save Options
To select the panorama saving options:

1. Open the Record panel.

2. Select RWNSaver from the Animation Type pop-up menu.

3. Click the Save Animation button.

 A file selection dialog box will open.
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4. Browse for the selected file location and enter the desired
filename for the panorama.

 The filename should end with the .PAN file extension.  This
filename will be augmented with a number for each panorama
rendered in a multiple panorama sequence.  For example,
entering MYPAN.PAN for a sequence of two panoramas will
result in the files MYPAN000.PAN and MYPAN001.PAN being
created.

5. Click the Open button to close the file selection dialog box.

6. Click the Continue button to close the Record panel.

Rendering the Panorama
Next, begin rendering the images and select the panorama parameters.
Note: The rendering process cannot be done in batch mode.

1. Click the Render button.

2. Select a sequence of some multiple of six frames to render,
beginning with a multiple of six (i.e. 0, 6, 12, etc.).

 For example, choosing frames 0–11 or frames 6–17 will
result in the creation of two panoramas.  This is very
important.  Without at least six frames, panoramas cannot be
generated.

3. Select a Frame Step of 1.

 This is also very important.  Without a frame step of 1, the
panorama saver will not obtain the appropriate sets of frames.

4. Choose a method of Frame Advance.

5. Click the OK button to begin rendering.

 The Real World Navigation Plug-in dialog box will open.

6. Enter an appropriate size for the panorama image.

 The displayed size of the panorama will be a default size
based on your camera settings.

7. Select the desired compression settings.

 For more information about compression, see the following
discussion, “Compressing SmoothMove Panoramas.”
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8. The Suppress View Window check box will be disabled.

 Panoramas are not automatically displayed when rendering a
sequence of more than one panorama.

9. Click OK to begin rendering.

 The individual frames of each panorama will be rendered.
When the last image of each six image sub-sequence is
complete, the Real World Navigation animation saver will
seam the images and save a panorama.

When the panoramas are complete, they can be viewed with any
application that is enabled for SmoothMove panoramas.  To associate
actions with regions of the image, use the HotSpot Editor.

Compressing SmoothMove Panoramas

Why should you compress panoramas?
One very obvious benefit of compression is that your SmoothMove
panoramas will take up less disk space.   With compression, it takes less
time to download a panorama from the Internet.  Of course, when you’re
creating panorama files for distribution, compression is essential.

When is the best time to compress?
Here’s an outline that illustrates the “life cycle” of a panorama:

1. Create the panorama from source files (3D models or
photographic images).

2. “Annotate” the panorama with hotspots.

3. Edit the panorama.  You can touch it up in a painting
program or make adjustments to the panorama’s orientation.

4. Compress the panorama.

5. Distribute the panorama, usually on your Web page or on a
CD-ROM.

6. View and use the panorama in the SmoothMove Viewer or in
LightWave 3D.
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As you can see here, compression generally takes place after you’ve made
all your changes to the panorama, but before you’ve begun to distribute it
widely.  Let’s take a look at what’s actually involved in compressing a
panorama.

How to compress your panoramas
Most tools in the Real World Navigation family of products have
integrated compression tools.  Those that don’t, have an external
compression program.

For general distribution of images, Infinite Pictures uses JPEG, because the
JPEG compressor is portable to Macintosh and other non-Intel
architectures.

JPEG

Currently, JPEG is the de facto standard for lossy image compression on
the Internet.  JPEG provides greater image compression because it does not
attempt to decompress images into a perfect copy of the original.

When compressing, you can choose the compression level, from 0 to 100.
Choosing low numbers yield smaller files, but poorer image quality.
Choosing high numbers yields larger files, but higher image quality.

You’ll want to experiment, and choose the file size and image quality
tradeoff that is appropriate for your application.

With JPEG, we recommend a compression level of 70 for files that will be
distributed on the Internet, or 75 for files that will be distributed on CD-
ROM.

Indeo

Intel Indeo Video Interactive was designed to compress individual frames
for video movies.  Indeo works on Intel architectures, and offers state-of-
the-art compression.  Files are smaller than with almost any other
compression algorithm.  Indeo does require lots of memory  –
decompression can require up to 90 MB of RAM.  This may present
problems in situations such as Web pages, where panoramas are often
viewed by users whose computers have limited memory.
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As with JPEG, Indeo has a compression level that ranges from 0 to 100.
We have found that a compression level of 65 typically yields images
smaller than 200K (for panoramas of size 2048x1024).

With Indeo, we recommend a compression level of 65 for files that will be
distributed on the Internet, or 80 for files that will be distributed on CD-
ROM.

Although Indeo is designed to be faster than JPEG, we have found that
with typical panorama files (2048x1024 pixels), the memory requirements
are so high that the operating system must page to disk.  It is not
uncommon for Indeo panoramas to take 15-30 seconds to display on
machines with less than 32 MB of RAM – with 64 MB, it takes only 3-4
seconds.
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Troubleshooting

Here are some tips to make you more successful at rendering and viewing
SmoothMove panoramas:

Problem Solution

Real World Navigation
Suite for LightWave 3D
does not load.

The Real World Navigation Suite works only on
Intel-based computers.

When I render a panorama,
LightWave 3D appears to
freeze after the final frame.

The animation saver portion of the plug-in is
probably seaming the six source images into a
panorama.  The time necessary for seaming and
compressing depends on the image size and
processor speed of the computer.  It can take a long
time on some computers.  The seaming and
compressing is done when the frame buffer is freed.

The panorama appears to
be upside down.

The SmoothMove panorama uses the orientation of
the camera to determine a default viewing
direction.  Be sure that the camera’s top is in the
direction of the desired panorama’s top.

I can’t load the tutorial
files!

In LightWave 4.0 and 5.0, you cannot load a scene
file whose pathname is longer than LightWave’s
limitation.  To shorten the pathname, copy the
tutorial directory to a location closer to the root
directory.  Then load the scene from the new
location.
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Problem Solution

The quality of the
panoramic image appears
to be much lower than
expected.

Try using a larger panorama.

Image quality also depends on the compression
settings.  JPEG is a lossy compression scheme.

The panorama looks like
the inside of a box.

This is probably due to visibility of the seams.
When rendering in wireframe mode, the seams are
often visible because of the way LightWave clips its
polygons.  Other causes might be the use of time
based effects that change objects or surfaces
between frames of the rendered image sequence.

For current information about the Real World Navigation Suite for
LightWave 3D, please visit our Web site at http://www.smoothmove.com.

http://www.smoothmove.com
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